I'm having trouble adding a user in Brainzy

We are sorry you are experiencing some technical issues while using our Brainzy program.  As you might know, Brainzy performs best in Chrome. Brainzy can also be played in IE 10 (or higher) or in Firefox 4 (or higher). We do not currently support earlier versions of IE or Firefox. If you're using an unsupported browser, we hope you'll consider upgrading your browser to optimize your Brainzy experience. You can download Chrome by visiting www.google.com/chrome.

Please contact us if this does not get you up and running.

Did you find this article helpful?